Start a new topic

Grounding RCA's, SMPS, and Chassis - Best Methods?

Grounding RCA's, SMPS, and Chassis - Best Methods?

2930

32

Integrated Amp using VC23 and T1:

Given:



A IEC socket ground to chassis

B Aluminum brackets supporting VC23 and T1 attached to SMPS case.

C SMPS case bolted to chassis



Questions:

Should SMPS be grounded to chassis at ground terminal strip at back?

Should any ground wires be run to the chassis ground from the VC23 or the T1, or is grounding through the bracket supports adequate?

Should the RCA input ground lugs be connected to the shield wires for the VC23 inputs?

- If so, should the RCA input ground lugs be used on the L AND R, or just one or the other?

Is connecting the input ground even necessary if the RCA inputs are grounded to the chassis and the boards are grounded to the chassis through the board mounting brackets? Trying to avoid ground loops and hum.

Also should the ground terminal on the Meanwell SMPS terminal strip be run to the case ground?
I answered some of my own questions:
1. The ground on the terminal strip is connected to the SMPS chassis, so if the SMPS case is bolted the case that ground path should be OK.
2. The PCB mounting holes and pads are not connected to ground, so don't count on that for board ground. Wish I would have known that, then I could have used the nylon PCB supports I had and didn't need to buy aluminum supports :-(
3. All of the center input connectors on the VC23 preamp are connected together, so not sure if you need to run all grounds to the RCA inputs, or just one. Maybe it is good to run the ground wire and not connect it to the RCA's for shielding, IDK.
4) Board mounting points are not grounds.

While all that is well and good, there is no output from the amp. Voltage is good going in to both points on the preamp 26-0-26, and 12.6 VDC, and 30VDC from SMPS to T1, both D3 and D11 LED's are on. The soldering iron did touch C36 while trying to access the mute and ground pads between C36 and the heatsink. Would this kind of damage prevent the T1 from working?
Tried running input directly to T1 and still no output.

Any help greatly appreciated.

Thanks.
Login or Signup to post a comment