Start a new topic

remote control/ir reciever problems

remote control/ir reciever problems

The remote control for my ddx 320 no longer works, except to turn on/off the amp, mute, switch channels down, but not up, and volume up or down.

Tried replacing batteries with new cells, but they were the same voltage. Tried changing dip switch settings, nothing works. Occasioinally after pressing the other buttons randomly, i get eq switching, but nothing else. None of the other buttons work.

This may have been caused by stress on the display/ir pcb when mounting, ie there was a mm of flex stess or so, but i doubt thats the issue.

Any tips on how to diagnose if this is the reciever or the remote?

Any option to replace both parts, or what components i could buy to do so myself? Ie the caps/resistors in the ir/lcd pcb, or the single (resistor i beleive) in the remote?

Is there some kind of reset pin that can be jumped that may fix this? Somewhere on the jtag, bsl or m1 pinouts on the board? If so, how would i do this? Jump them to dgnd; vd3.3? Should the device be powered on when doing so?

I checked all the pins on the cable going from the j3 serial port to the ir/lcd pcb, and they're are no shorts, or broken wires. At a loss here, would really apprecciate some help/advice as to what the problem may be here.

As well, the 4 dip s1 switch, just to confirm-

for a 4 input, no led auto-off, 2.1 mode, tst mode off, which switches should be pushed down?

I think something is wrong here, as with only switch 2 pushed down (off i assume, since the led's don't auto turn off) i get 4 input selection (not 8) and 2.1 mode. That doesn't make sense, as 1/2 should be in the same position for such operating parameters observed. And just to confirm, even though i'm fairly certain on this, when the pin is in the closed state (pushed down) that correlates to an off logic state? If so, why do i get 4 inputs vs 8 inputs when swith 1 is open (not pushed down?


my dip config is this-

p1- up
p2- down
p3- up
p4- up

and i get 4channel selection, no disp auto-off, 2.1, and idk how to know when its in test mode, other than the volume jumps +10 when the switch is pushed down.

Finally, after fiddling with the switches to be able to describe this behavior, all the control buttons are working now. Switch 1- down 8 channel selection available, switch 2- down no auto display off, switch 3- up 2.1 enabled, switch 4- down 10+ volume diffrence between if its down (when i say 10+ i mean IE 40 to 30, since the lower it displays the louder the amp is).

Very strange. This seems to happen when power is switched on/off. Am i doing the power switching wrong, by just unplugging a 3 pin d computer female connector lead (the connnector found on the back of an atx supply) to a 3 prong ac, 3 pin male d cable? This is at the smps of course. I have the dc out of the smps attached to the amp without any switches/relays.

Eventually, i'd like to get a rf power remote for both the ac/dc connections, using relays to dpst each on/off. Let the smps power up, then switch on the dc out to the amp, then ir remote power on the amp. Another thing that has been nagging at me, is how would doing both (dpst power switching of +/- ac smps power, +/- dc smps to amp power, on one rf controlled relay board, well within current/voltage ratings for each of course) affect sound quality? Is there going to be noise/distortion by using a 2 channel rf relay remote dpst board? IE having the ac/dc switches so close together on the same board?

Another option, would be to use a 2 channel spdt board, to cascade trigger two additional spst relays inside my amp enclosure, wiring in a 5v/12v/etc voltage source to power the relays and the other dpst to switch the ac in the rf relay project box near the smps?

I know, lots of questions, but i wan't to do this right, and figure out why the dip switches are acting funny, and implement rf on/off control for both the smps dc out to the amp/smps ac in power without affecting sound quality having the realys on the same board.

Any suggestions are most welcome.
Same here with my remote. In my case it is very erratic and the only feature that works is the power on/off. All other buttons on the remote only respond occasionaly and then they change the EQ setting regardless of which button I press. Took 15 min. to get the EQ back to "off" (E----).
Login or Signup to post a comment