Start a new topic

Anyone tried Sabre USB DAC with Galaxy S3 phone

Anyone tried Sabre USB DAC with Galaxy S3 phone

Hi

Apologies if this has been mentioned - could not pick anything up on a search..



Has anyone tried this dac with the new phones with PC like usb hub function.. eg galaxy s3



if so - did the volume on the phone work ok?

what was the current train on the system?

did it sound good?



thanks for any help...



Ported
Hi

Apologies if this has been mentioned - could not pick anything up on a search..



Has anyone tried this dac with the new phones with PC like usb hub function.. eg galaxy s3



if so - did the volume on the phone work ok?

what was the current train on the system?

did it sound good?



thanks for any help...



Ported



I took the punt so can answer my own question - No it does not... DOH! It seems to fire up and look ready and headphone out from S3 is muted but no output from DAC. Using it on my PC though shows a big step change in quality for music reproduction although sync with video seems poor..is this the asynchronous nature of things here? There seems to be one android app that will interface ok USBAudioRecorderPRO but that is a mini multi-track recording system - Lets hope the technology here can be broadened to play mp3 etc or even direct all audio output...



If anyone knows any more please post details...



Ported
Hi, thanks for giving it a try! I believe it not working on android is related to android version, later or coming versions of android might work. which version did you try with ?

concerning video/audio sync, is this with windows? which version? which program did you use ? We have not experience this issue.
Hi, thanks for giving it a try! I believe it not working on android is related to android version, later or coming versions of android might work. which version did you try with ?



concerning video/audio sync, is this with windows? which version? which program did you use ? We have not experience this issue.



Android is version 4.1.2 and windows was 7 pro patched to date - just watching a couple of you tube vids - I changed back to onboard and all seemed good... I will try again to see if its general or just a glitch..



Ported
Android is version 4.1.2 and windows was 7 pro patched to date - just watching a couple of you tube vids - I changed back to onboard and all seemed good... I will try again to see if its general or just a glitch..

Ported

I think it just draws too much resource from my PC as the sync problem only happens at full screen - a few years old now relying on on-board graphics.. more interested in music output which has vastly improved - so not a big issue.. Ported
Login or Signup to post a comment