Start a new topic

Sabre DAC killed my audio?

Sabre DAC killed my audio?

I plugged the sabre dac into my system and I think it wrecked the sound drivers. I get all types of strange problems. warbling, muffling, ringing etc. even after disconnect and switching to a different audio system. I think my default sound drivers are damaged and I can't seem to repair them.
Hi, this sounds very strange. but can you give us some more info? computer system, software etc? Did you install any drivers?
I plugged the sabre dac into my system and I think it wrecked the sound drivers. I get all types of strange problems. warbling, muffling, ringing etc. even after disconnect and switching to a different audio system. I think my default sound drivers are damaged and I can't seem to repair them.



All USB sound now is terrible no matter what device I use. I tried refreshing windows 8 but, that didn't fix the trouble. could the Sabre have tried to draw too much power and fried part of my motherboard or could it still be a software problem?
Hi, it's unlikely that the sabre has drawn too much power as you say. usb ports have protections for that.
I advice you to try the sabre dac on another computer, any issues there?
Check all mixer settings. Maybe some settings has been changed, too high gain could result in distorted sound.

What about internal sound from your win 8 computer, is that still normal?
Did you previously install any other drivers?
Hi, it's unlikely that the sabre has drawn too much power as you say. usb ports have protections for that.

I advice you to try the sabre dac on another computer, any issues there?

Check all mixer settings. Maybe some settings has been changed, too high gain could result in distorted sound.



What about internal sound from your win 8 computer, is that still normal?

Did you previously install any other drivers?



Headphones ended up being the culprit. Fa-011 to the trash bin now :/
Login or Signup to post a comment