Start a new topic

9018 output delay issue

9018 output delay issue

1 person has this question

I've run into a strange issue with my 9018 for the last month and a half now. I've noticed that there seems to be an output delay between a half a second to a second before it outputs a signal (err, sound) to my speakers/headphones. This causes the first half a second to a second to be silent. I'm aware this is an issue with optical outputs like S/PDIF, with a workaround being a "S/PDIF keepalive" type of program...

However, I don't use the optical output. Ever. In fact, I'm only using the analog output from the 3.5mm connector. But here's the thing, even though I'm using the analog output the optical light inside is on constantly. I've tested this on Windows, Mac OS X, Ubuntu and Android 4.4.4 and 5.0 with my Behringer MS40 studio monitors and various pairs of headphones and the result is the same. For whatever reason, there's an output delay. I've also noticed that sometimes there's a small 'pop' sound as the DAC is being initialized for output along with the same 'pop' after stopping music as if the DAC is going into standby. It's like even though I'm using the analog output the optical is still being initialized and thus the output delay occurs on the analog. Because of this, for example, I've had to disable the OS sounds for Windows, Mac and Ubuntu due to the delay causing them not to be heard.

I've been able to workaround this, in a way on Windows, by adding a 1 second "prebuffer" to both JRiver Media Center on Windows/Mac/Ubuntu and MPC-HC on Windows and it seems to work fine. However, if I load up a browser like Google Chrome or Firefox and try to view a video on YouTube on Windows/Mac/Ubuntu, the delay is present.

So, what I'm wondering is if there's a) a fix for this issue or b) if the optical can be disabled completely so the analog can be 'on' all the time without these audio delays.

Thank you.
This issue is not because of the optical signal, it's cause by the ES9018k2M dac chip, I'm afraid the only solution is to increase buffer, as you have done in the player already.
In order to get lowest THD the register should be set to 3'd7 as the datasheet suggests.:
http://forum.hifimediy.com/attachment.php?attachmentid=81&stc=1

So lower THD is achieved with the drawback of bigger delay when first starting to play sound.
The delay will increase with higher sample rate, so it will help to set sample rates higher to reduce the delay.
48khz sample rates will unmute with 93.75dB/s, so volume will go from mute to about -30dB in around 1 sec, 96khz takes 0.5sec. 192khz takes 0.25sec and384khz takes 0.125sec.
How do you increase the buffer system-wide on Windows, Mac and Linux if it's possible?
Just wondering, does the UH1 suffer from the same 'issue' since it's using a TI chip?
How do you increase the buffer system-wide on Windows, Mac and Linux if it's possible?
No this is a setting in the DAC, so it's not possible. However on the new version of 9018D we have added a setting so you can chose the delay. Either shorter delay with slighter higher distortion, or longer delay with better distortion.
Just wondering, does the UH1 suffer from the same 'issue' since it's using a TI chip?
No, this is related to the ES9018k2m chip, and doesn't occur in PCM5102.
No this is a setting in the DAC, so it's not possible. However on the new version of 9018D we have added a setting so you can chose the delay. Either shorter delay with slighter higher distortion, or longer delay with better distortion.

Interesting. So on the new 9018D with this new delay selection setting, I can achieve what I'm looking for when selecting the shorter delay? Meaning no audible delay when first starting playback? Is the setting saved within the hardware so I can use other OSes without issue too?
However, this quicker unmute function has some bugs, it seems to often add noise when this new setting is selected. So we have to recommend to use the normal longer unmute setting for now.

The delay has been reduced to about 0.1 second on newest es9018k2m chip used in recent production.

That's great to hear!


Because of the delay issue with the (first?) version I have, I had to quit using it as the delay in daily use was rather... annoying, especially with YouTube videos in web browsers where the first second was silent.

Is there a way we can get around this setting the buffer in Foobar for example? 

I tried another brand dac that uses this same chipset and there is no delay in starting playing audio and no audible worse sound at the start. Is there a firmware or driver fix you can offer? on the SABER9018 USB DAC D I get about 3 seconds of silence before the song comes in. 


I like the other features on the HiFiMe Dac but the clipping of songs is a deal breaker. Is there a way to compensate for this, or to try a new driver package? I'd really rather stick with this Dac.

@Bill Street,

this is the 9018D model (with a display right)? The workaround is to set the samplerate to 192kHz or 384kHz. The newer produced unit uses another version of the chip (V vs W) which enables a much lower fade in. 

@Nick

The delay has been reduced to about 0.1 second on newest es9018k2m chip used in recent production.

Which models have this newest chip (and which ones don't)?


Is this the same thing that you were talking about here (0.1 sec delay, and much lower fade in, are both in the same new chip -- they are one and the same)?

The newer produced unit uses another version of the chip (V vs W) which enables a much lower fade in. 

 Thx.

Login or Signup to post a comment