Start a new topic

9018 output delay issue

9018 output delay issue

1 person has this question

How do you increase the buffer system-wide on Windows, Mac and Linux if it's possible?
This issue is not because of the optical signal, it's cause by the ES9018k2M dac chip, I'm afraid the only solution is to increase buffer, as you have done in the player already.
In order to get lowest THD the register should be set to 3'd7 as the datasheet suggests.:
http://forum.hifimediy.com/attachment.php?attachmentid=81&stc=1

So lower THD is achieved with the drawback of bigger delay when first starting to play sound.
The delay will increase with higher sample rate, so it will help to set sample rates higher to reduce the delay.
48khz sample rates will unmute with 93.75dB/s, so volume will go from mute to about -30dB in around 1 sec, 96khz takes 0.5sec. 192khz takes 0.25sec and384khz takes 0.125sec.
I've run into a strange issue with my 9018 for the last month and a half now. I've noticed that there seems to be an output delay between a half a second to a second before it outputs a signal (err, sound) to my speakers/headphones. This causes the first half a second to a second to be silent. I'm aware this is an issue with optical outputs like S/PDIF, with a workaround being a "S/PDIF keepalive" type of program...

However, I don't use the optical output. Ever. In fact, I'm only using the analog output from the 3.5mm connector. But here's the thing, even though I'm using the analog output the optical light inside is on constantly. I've tested this on Windows, Mac OS X, Ubuntu and Android 4.4.4 and 5.0 with my Behringer MS40 studio monitors and various pairs of headphones and the result is the same. For whatever reason, there's an output delay. I've also noticed that sometimes there's a small 'pop' sound as the DAC is being initialized for output along with the same 'pop' after stopping music as if the DAC is going into standby. It's like even though I'm using the analog output the optical is still being initialized and thus the output delay occurs on the analog. Because of this, for example, I've had to disable the OS sounds for Windows, Mac and Ubuntu due to the delay causing them not to be heard.

I've been able to workaround this, in a way on Windows, by adding a 1 second "prebuffer" to both JRiver Media Center on Windows/Mac/Ubuntu and MPC-HC on Windows and it seems to work fine. However, if I load up a browser like Google Chrome or Firefox and try to view a video on YouTube on Windows/Mac/Ubuntu, the delay is present.

So, what I'm wondering is if there's a) a fix for this issue or b) if the optical can be disabled completely so the analog can be 'on' all the time without these audio delays.

Thank you.
Login or Signup to post a comment